Bug #192

Garbage Manager creates deadlock

Added by Adam Giemza over 4 years ago. Updated over 4 years ago.

Status:ClosedStart date:01/07/2013
Priority:UrgentDue date:
Assignee:Adam Giemza% Done:

100%

Category:-
Target version:4.0.0

Description

GM creates deadlock on locking Tuple templates in ServerCommand.

Associated revisions

Revision 884
Added by Adam Giemza over 4 years ago

Resolved dead lock in template locking, fixes #192

History

#1 Updated by Adam Giemza over 4 years ago

  • Status changed from New to Closed

The very seldom dead lock was caused by a too early notification (notify) of a not yet waiting (wait) thread. The reason for this might be a non atomic execution of the lock release for the template and the call of the wait.

Punch line: It was not the Garbage Manager but a more general problem, which is fixed now yay

#2 Updated by Adam Giemza over 4 years ago

  • % Done changed from 0 to 100

Also available in: Atom PDF